Description:

Easy and light script to automate adding a context menu to Nautilus / Gnome Files to create a new document.

** Built in GNOME nautilus 3.22.3; not tested in other versions. **

Likely will not work in 3.26 as Nautilus is removing desktop icons. If you use Debian/Ubuntu-based distros (and haven't updated yet) you can disable Nautilus from getting this update:
apt-mark hold nautilus

If you already updated, simply downgrade the Nautilus package and run that command to prevent it from updating.

To use:
- Either download the zip -or- clone the Not a Bug code repository.
- (If zip): unzip the archive
- In your terminal, navigate to the directory where the files are located, then run:
./automate.sh ...and the script will put the needed files in place for your context menu.


If you need help, or want to contribute improvements to the script, please open an issue (or pull request) on Not a Bug: https://notabug.org/angela/nautilus-right-click-new-file/issues
Last changelog:

v1.0.1 10 days ago

Cleaned up file prefixes; no structural changes from v1.0. If you already have the context menu, upgrading won't be useful to you.

dboon7888

1 month ago

amazon phone number

Report

dboon7888

1 month ago

https://www.servicedonline.com/amazon-phone-number/
Nice post

Report

3rPha

2 months ago

Can't you do the same thing by creating a new file in your /home/user_name/Templates
folder ??

Report

C

angela-

2 months ago

If you look at the manual instructions on Github, that's exactly what this does, except this script automates it. It saves an enormous amount of time when you have to do it on multiple desktops!

Report

OLucasZanella

2 months ago

Couldn't do it in 3.26.2

Report

C

angela-

2 months ago

If I am not mistaken, 3.26 introduces the "fix" of where the Nautilus devs remove desktop icons completely: https://www.omgubuntu.co.uk/2018/01/ubuntu-18-04-lts-will-ship-older-version-nautilus

So in order for my script to work, you'd either need to be running an older version ,or downgrade the Nautilus package.

Debian is still running 3.22

Report

v1.0.1 10 days ago

Cleaned up file prefixes; no structural changes from v1.0. If you already have the context menu, upgrading won't be useful to you.

File (click to download) Version Description Packagetype Architecture Downloads Date Filesize DL OCS-Install
Pling me
Details
license
GPLv3
version
1.0.1
updated Jun 09 2018
added Mar 30 2018
downloads today
0
page views today 7
System Tags gplv3 addon